can't use ResamplerDMO..??

Jun 9, 2008 at 10:34 AM
hello, I was so happy when I found  your project library..I thought that gonna save a lot of time in my project..
I'm trying to resample wave and mp3 files to convert them after to ccitt alaw file,
I tried to use the released DLL and the test you wrote with samplerDMO...but I didn't find the DMO class, so I compiled the latest source project you have ..and tried again ..but I still have a problem to create the DMO object..I also downloaded the SamplerDMO.DLL and tried tô register it..but this not working!!
it said :"COMException: can't load COM class with CLSID {F447B69E-1884-4A7E-8055-346F74D6EDB3} "
thank in advance for your help.
regards,
Walid
Jun 9, 2008 at 1:25 PM
hello again, can we have please the last version of your DLL???
please
Coordinator
Jun 9, 2008 at 4:10 PM


zwalid wrote:
hello again, can we have please the last version of your DLL???
please


Hi Zwalid. ResamplerDMOStream is a very new feature of NAudio and is still a work in progress. It would appear that your PC doesn't have the COM object registered. Can I ask what operating system you are using? I was developing on Vista, and haven't got round to seeing what happens in XP yet.
I am planning to release a new version of NAudio in the coming weeks though, but for now there is nothing stopping you downloading the code and compiling your own.

Mark
Jun 10, 2008 at 7:48 AM
hello,
Thanks for your answer Mark.
I'm using Vista, and I did compile the latest version of your source code "1.2.128.0" , the same like you did use in your resamplr jigg example.
like you said,I think the problem is that my resamplrdmo COM object is not registered on my PC.
actually, I did add resamplerDMO.dll to my /system32  and tried to register it ...but still not working ..I'm still having this loading problem....
do you have any hint to how solve this problem..
thank a lot.
regards,
Walid
Coordinator
Jun 10, 2008 at 7:02 PM
hi Walid,
I'm surprised resamplerdmo.dll isn't on your system already. It is on mine. What edition of Vista are you using?
Jun 22, 2008 at 11:59 AM

hello,
that's me again...I did solve the problem..Actually it was a missing DLL
I'm win XP pro, but I don't know why this DLL was missing...anyway, I found this DLL and it' dependency..and now, it's working fine ..the resampling is working great..thanks a lot  ;)
this resampling was just a small part of my project, what I'm trying to do is converting MP3 to  wave(CCITT ALAW 8khz mono) for our phone application ..and lately I found something similar to this in your library..is it possible to be done with NAudio????
..cause I'm stuck with directShowNet..I can't get it working..
thanks in advance.
cheers,
Walid
Jul 25, 2011 at 2:18 PM

Only for completeness.

The missing dll zwalid mentioned seems to be usually mfplat.dll. The resampledmo.dll  and mfplat.dll have to be copied to C:\Windows\SysWow64\ (x86 Project) or in standard C:\Windows\System32\ directory for x64 architecture and on 32 bit systems.

Just register the resampledmo.dll with the dedicated regsvr32.exe. Then type in the cmd line in the system directory   "regsvr32.exe resampledmo.dll".

For me, that did the job on a x64 windows server 2008 R2 system.

Coordinator
Jul 26, 2011 at 9:43 AM

thanks for the info knoerzer