This project has moved. For the latest updates, please go here.

What ASIO version do NAudio max. support? 2.2? 2.0? 1.0? 3?

Apr 12, 2011 at 9:26 AM

max. ASIO v.2.2 now?

Coordinator
Apr 12, 2011 at 9:42 AM

I'm afraid the NAudio ASIO support is very elementary and doesn't work on all devices. It is recommended that you make use of WaveOut, DirectSound or  WASAPI instead

Apr 16, 2011 at 5:06 AM

Nope nope nope, of course I know that.

But ASIO have it's own version
http://www.steinberg.net/nc/en/company/developer/sdk_download_portal/asio_sdk.html

(Version ”2.2 – October 2005”)

 

So what is the version of your ASIO? newer ASIO versions are downward compatibility

Coordinator
Apr 16, 2011 at 7:17 AM

I recently did a bugfix for NAudio ASIO and used the latest ASIO SDK (2.2) as my reference point. From NAudio we only call ASIO API's that have been around for a long time. I couldn't tell you what exact "version" it is.